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Part 1 - New Functionality 

What's New in CabWriter 5 - Part 1 Video Timeline 
Time Feature 

1:36 One Piece Shaker Style 

8:09 Mid-Rails in Doors & End Panels of Divided Cabinets 

   15:22 Automatic Texturing 

24:48 Automatic Elevation & Section Views 

38:13 New Box Schedule Report 

One Piece Shaker Style 
A new style for doors, drawer fronts, end panels and 

back panels has been added, called One Piece Shaker. 

This style is essentially the same as a slab or sheet 

style for doors/drawer fronts and end or back panels 

respectively. The difference is that a recessed field is 

cut in the middle to make it look like a basic Shaker 

style. The stile and rail dimensions follow the normal 

defaults for a frame & panel door/ drawer fronts or 

end and back panels. The primary use for this style is 

to provide a means for cutting door/drawer fronts, 

end and back panels on a CNC machine, while 

emulating a basic Shaker frame and panel look. Figure 

1 shows an example of this style. 

Note that you can still use the Trim/Banding feature 

too, by setting the Enable CNC Cutting parameter to 

Yes in the General section of the Project tab. In fact, if 

you are going to use this style, and are going to mill 

the components on a CNC, you should use Enable CNC Cutting to avoid having to cut the components 

down later to allow for the Trim/Banding. 

To accommodate the new One Piece 

Shaker style, several new parameters 

were added. A new parameter has been 

added to the CNC Setup tab, shown in  

Figure 2, to set the depth of the field.  

Figure 1 One Piece Shaker Style 

Figure 2 Field Depth parameter for One Piece Shaker style 
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Figure 3 One Piece Shaker parameters on the Doors tab 

Also, a new option, called One Piece Shaker, has been added to the Doors, Drawers, and Panels tabs, 

shown in Figure 3, Figure 4 and Figure 5 respectively. 

 

Figure 4 One Piece Shaker parameters on the Drawers tab 

 

Figure 5 One Piece Shaker parameters on the Panels tab 

In Figure 6 is a sheet optimization for a One Piece Shaker set of doors and drawer fronts.  

There are a few things to be aware of when using this style: 

a. The end panel modeled with this style is still called a Right/Left End Sheet, and they will appear 

on the Base/Upper End Panels tag (layer). 

b. In the Materials section of the Materials tab, you must use the Slab Door/Drawer Front and End 

& Back Sheet parameters to specify the material for these parts. 

c. The material thickness is determined by Door/Drawer Front Thickness in the Base/Upper 

General Section of the Base/Upper Cabinets tab for door/drawer fronts; and Sheet Thickness in 

the appropriate section on the Panels tab for End and Back Panels. 

d. The One Piece Shaker End and Back Panels are essentially a End Sheet. Hence, while this style 

can be used with End Panel face frame stiles, best practices suggests that you use End Sheet 

stiles. If End Panel stiles are used their widths should be modified to account for the difference 

in thickness of the sheet material versus a frame and panel. 
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Mid-Rails in Doors & End Panels of Divided Cabinets 
In CabWriter 5 we added the ability to specify a mid-rail in the door and drawer fronts of Divided Upper 

and Divided Base cabinets. Figure 7 shows an assortment of cabinet styles, each with a mid-rail in its 

door fronts and end panels. This required addition of parameters and a re-arrangement of the Base 

Cabinets tab, shown in Figure 8, and the Upper Cabinets tab, shown in Figure 9. Notice there is one 

parameter on each tab in the Divided Base and Divided Upper sections labeled Door Mid-Rail Width. 

Also notice in Figure 10 that the Divided Box dialog box has a new column called Mid-Rail. The Option 

drop-downs have an additional choice called Divided Door, shown above right. 

If a door with mid-rail is desired, the user must select a Divided Door is and supply a non-zero dimension 

in the corresponding Mid-Rail field. This dimension is the distance from the bottom edge of the door to 

the horizontal center of the mid-rail. Note it is the bottom edge of the door and not the bottom of the 

door opening. The Mid-Rail column is ignored for any other choice in the Option column, i.e. None, Door 

or Drawer. 

We also implemented the ability to add mid-rails to the end panels of Divided Base, Divided Upper and 

Refrigerator Upper cabinets. In the case of a Refrigerator Upper, the sides must be extended to the 

floor. New parameters called End Panel Mid-Rail Width and End Panel Mid-Rail Position have been 

added to the Divided Base, Divided Upper and Refrigerator Upper sections of the Base Cabinets and 

Upper Cabinets tabs. See Figure 8 and Figure 9. If the End Panel Mid-Rail Position parameter is exactly 

Figure 6 One Piece Shaker parameters on the Panels tab 
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0.0, no mid-rail will be drawn. If a non-zero End Panel Mid-Rail Position parameter is specified, a mid-rail 

will be drawn at that position. The reference for the mid-rail position is the bottom of the panel to the 

horizontal center of the mid-rail. 

The addition of mid-rail capability required changes in the Door & Drawer Report. Figure 11 shows the 

new Door & Drawer Report. All the changes are in the Frame & Panels Doors section. Notice that to the 

right of the Frame Material column are three columns labeled Panel Material, Top Panel Material and 

Bottom Panel Material. Top Panel Material and Bottom Panel Material are new. In doors with no mid-

rail there is only one panel and its material will appear in the Panel Material column. The Top Panel 

Material and Bottom Panel Material for this one panel door will be labeled N/A, not applicable, as 

shown in line 24 of Figure 11. For doors with a mid-rail, there are two panels and their material will be 

found in the Top Panel Material and Bottom Panel Material columns, and the Panel Material column will 

be marked N/A, as shown in lines 20 through 23. 

To the right you will find two more columns: Mid-Rail Width and Mid-Rail Position. If there is a mid-rail 

in the door its width will be found in the Mid-Rail Width column and the mid-rail’s position will be found 

in the Mid-Rail Position column. If there is no mid-rail in the door this entry will be marked N/A in both 

the Mid-Rail Width and Mid-Rail Position columns. 

Note: The dimension in the Mid-Rail Position column is the distance from the bottom edge of the 

Bottom Rail to the mid-point of the Mid-Rail.  

Figure 7 A collection of cabinets in various styles, each with Mid-Rails in the Doors and End Panels 
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Figure 8 Base Cabinets tab with new parameters for mid-rails 



      7 

 

Copyright 2012 - 2021 CabWriter Software LLC - All Rights Reserved Page 7 

   

Figure 9 Upper Cabinets tab with new parameters for mid-rails 
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Figure 10 The Divided Box dialog box with new Divided Door option and Mid-Rail column 
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Figure 11 Door & Drawer Report changes made to accommodate Mid-Rails 
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Automatic Texturing 
Texturing cabinets can be very helpful when displaying a design to a client. Prior to CabWriter 5, the 

cabinetmaker had to use native SketchUp tools to accomplish this, and that was very time consuming, 

and the textures supplied with SketchUp are less than acceptable. We have added several automated 

methods of texturing and provided the cabinetmaker with approximately 250 real wood grain textures. 

Since wood grain textures are actually part of the materials definition, we added a Texture column with 

eight texture parameters to the Materials section of the Materials tab, shown in Figure 12. These eight 

parameters coincide with the eight component types, material types and material names. We have also 

added a Texture Preview window so the user can see the texture chosen for a given Material 

Type/Material Name combination. 

These eight textures drop-downs are parameters like any other CabWriter parameter; they are stored in 

the defaults in each cabinet component. The user should, before drawing the first cabinet of a model, go 

to the Materials tab and set up all material Types, material Names and material Textures. Having done 

that, when a cabinet is drawn it will automatically be textured. 

When cabinets are first drawn, they are automatically textured. Textures can be changed with a cabinet 

edit or re-draw, just like any other parameter. Further, we have added to new commands: Draw > 

CabWriter > Texture Model and Draw > CabWriter > Texture Selected. These are automatic texturing 

commands. The first textures the entire model; any CabWriter part, except custom parts (CP in the 

prefix) and walls will be textured. The second will texture whatever parts are selected provided they are 

CabWriter parts and not custom parts or walls. 

Whatever way the user chooses to texture, CabWriter will adjust for grain direction, including in the 

carcass parts because it uses the auto-grain correction feature of CabWriter. Using the commands 

Texture Model and Texture Selected will always texture using the current contents of the CabWriter 

settings. However, when editing or re-drawing a cabinet, you will be asked, as always, whether to use 

the stored defaults or the current CabWriter Settings. So, in the latter case, the choice will determine 

the textures used. 

There are eleven factory installed texture patterns that come with CabWriter 5. However, there are 

nearly 250 available from the CabWriter website. Look under the SketchUp menu for Download 

Textures. The user must be licensed and logged in to access the download files. 

The first image on the cover page of this document is an example of a textured model. Notice, you can 

texture with glass as well as wood grain. The custom parts, walls, counter tops, window trim etc. can 

also be textured using native SketchUp tools. 
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Automatic Elevation & Section Views (PRO & CNC) 
Extended the File > CabWriter > 

Create Basic Scene Set command to 

automatically generate all elevation 

and section views. This command now 

analyses all CabWriter cabinets and 

chooses a minimum set of section 

planes required to produce all 

elevation and section views. This 

required the addition of two defaults in the Section Plane Positions section of the Project tab shown in 

Figure 13. 

 

Elevation Offset – This parameter applies to only the Elevation views. It is the distance the section plane 

is placed in front of the cabinets. Typically, this means in front of the base cabinets in the view, but if 

there are no base cabinets, it will be placed in front of the upper cabinets by the distance specified. 

 

Section Offset – This parameter applies to only the Section views. It is the distance the section plane is 

Figure 12 The Materials tab showing the new Texture column and Texture Preview area 

Figure 13 New parameters in the Section Plane Positions section of the Project 
tab 
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placed inside the cabinets relative to their front face. Typically, this means inside the upper cabinets in 

the view, but if there are no upper cabinets, it will be placed inside the base cabinets by the distance 

specified. 

Create Basic Scene Set created 25 scenes automatically in the model in Figure 14. In addition to the 

usual scenes, it produced 8 Elevation scenes and 6 Section scenes. Scene tabs will be named Elevation A 

through Elevation (next letter) and Section A through Section (next letter). If necessary, the lettering will 

wrap to AA, AB, AC etc. In Figure 15 notice the naming of the section planes; BP is Base Plan, UP is Upper 

Plan and LP is Ladder Plan. Elevation view section planes begin with the letter E and then A through the 

next n letters. Section view section planes begin with the letter S and then A through the next n letters. 

E.g., The scene called Elevation A has a section plane labeled EA; the scene called Section D has a section 

plane labeled SD. 

 

VERY IMPORTANT: You should try to use the Create Basic Scene Set only once per model. Any changes to 

a scene should be done using Draw > CabWriter > Create Section From Section Plane.The reason this is 

important is, if you use Create Basic Scene Set again, each time you use it you will be duplicating section 

planes. If you feel you really want to run it again, you should first display only the section planes, select 

all of them and erase them. Then run Create Basic Scene Set again. 
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Figure 14 Gracie Hopkins Kitchen with 25 automatically created scenes including all necessary Elevations and Sections 
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Figure 15 Section planes used in the model with the new section plane labeling 
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New Box Schedule Report (PRO & CNC) 
Based on some email conversations and discussions in 

a Webinar, we have created a new report called the 

Box Schedule. This report is aimed exclusively at 

project costing, and should not be used for cabinet 

construction. Many cabinetmakers estimate project 

cost based on the number and length of each box 

type, number of doors, drawers and shelves. That is 

what this report provides. The report is a CSV file 

called box_schedule.csv. It has two sections, each with 

the same information, but sorted differently. The first 

section is simply by box number and the second 

section is by box type. The first section is most useful 

for checking correctness against a model and the 

second section is most useful for project costing. 

 

The Box Schedule report is part of the CabWriter 

Production Documentation set of reports. It requires a 

valid scene name assigned to the Cut List Report in the 

Scenes Used in Reports section of the Production 

Documentation dialog box shown in Figure 16. This 

scene is the same scene that is used to produce the 

cut list file. All Base and Upper box parts should be 

included in this scene, and there should never be 

duplicate instances; that is, never copy a box or box 

part and include that copy in the Cut List Report 

scene. Doing so would result in double accounting and 

raise the project cost beyond actual. 

Figure 17 is a snippet of the second section of the new 

Box Schedule Report.  Figure 16 Production Documentation dialog box with new 
Box Schedule Report 
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Figure 17 A snippet of the new Box Schedule Report 
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Part 2 - Functionality & Parameter Changes 

What's New in CabWriter 5 - Part 1 Video Timeline 
Time Feature 

1:24 Rough Lumber Report Replaces Stiles & Rails Report 

10:55 Redesigned Sheet Optimization Settings Dialog Box 

   16:33 Cut & Paste Instances on Optimized Sheet 

20:30 Eliminate Any Instances or Cabinets from Any Report by Hiding Them 

25:26 Construction Hole Depth 

28:49 Z-Depth Option 

30:38 Ladder Base Thickness 

 

Rough Lumber Report Replaces Stiles & Rails Report (PRO & CNC) 
Made major changes to the Stiles & 

Rails Report; in fact, it is no longer 

called Stiles & Rails Report, but rather, 

Rough Lumber Report. This new 

Rough Lumber Report, shown in 

Figure 18, now includes the following 

changes: 

 

a) In addition to door and drawer 

front stiles and rails, the Rough 

Lumber report now includes ladder 

base Applied Faces, Face Frame stiles 

and rails, End Panel stiles and rails and 

Back Panel stiles and rails. 

 

b) Ladder base Applied Faces are now 

placed on the Base Face Frames layer. 

 

c) Create Basic Scene Set no longer 

creates a scene called Stiles – Rails, 

but rather, Rough Lumber. This name 

change is reflected in the Production 

Documentation dialog box shown in . 

Figure 18 Production Documentation dialog box 
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d) The definition of rough lumber quarter thickness is now a set of CabWriter parameters that the user 

can change. A new section called Rough Lumber Specifications has been added to the Materials tab and 

shown in Figure 19. The Planed Thickness line is used to determine the crossover points between 

quarter thicknesses. The default shown are industry standard, but many suppliers have their own 

specifications. Some sell only rough-cut lumber and others sell both rough-cut and planed thickness 

lumber. Each user should check these settings against their supplier. 

 

Figure 19 The Rough Lumber Specifications section of the Materials tab 

 Notes of Caution: The Rip and Cross Cut reports are based on the Under-sizing/Oversizing dimensions 

reflecting the setting on the Cut List tab. If the user intends these to be final dimensions, then the 

applicable dimensions on the Cut List tab should be set to 0.0. 

Redesigned Sheet Optimization Settings Dialog Box 
Changed the way the left side of the Sheet Optimization Settings dialog box works. The new Sheet 

Optimization Settings dialog box is shown in Figure 20. The first thing to notice is that the select radio 

buttons, and the Add Line and Delete Line buttons, are gone. Also gone is the Thickness field in the 

Default Sheet Format section. The Available Sheet Sizes for Selected Material Name section has been 

renamed to Sheet Sizes by Selected Material Name. 

Sheet Optimization Settings creates and manages a file called sheet_goods_sizes.csv. This file resides in 

the directory specified on the Lists tab of the Extended Entity Info in the folder called Optimization Files. 

Each time the Sheet Optimization Settings dialog box is opened, CabWriter examines every sheet good 

component and makes note of its thickness and material name. It then checks to be sure there is an 

entry in the sheet_goods_sizes.csv for each material name and thickness combination. If it doesn’t find 

one, CabWriter creates and entry using the material name, thickness, default Width, default Length and 

default Has Grain?. This file can grow in size as you create more projects. This file is used during 

optimization to specify the sheet dimensions and whether the sheet has grain. Notice in the Sheet Sizes 

by Selected Material Name section under the Thickness column, that the thicknesses are greyed out. 

The user cannot change the thickness fields; those are determined by the thickness of components for 

each material name. However, the user can change the Width and Length fields. 

In the example shown at the top of the page, for a Metric project, there are three thicknesses of MDF 

material: 6.4 mm, 12.5 mm and 19.0 mm. Notice that the 12.5 mm and 19.0 mm thicknesses are going 

to be optimized on sheets of width = 1219.20 and length = 2438.40 mm, while the 6.4 mm thickness 

parts will be optimized on sheets of width = 1524.00 mm and length = 3048.00 mm. These sheet formats 

will be remembered in the sheet_goods_sizes.csv file and will be the same for a new project until the 

user once again changes them. 
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IMPORTANT: THIS MEANS THAT EACH TIME THE SHEET OPTIMIZATION SETTINGS DIALOG BOX IS OPENED THE USER 

SHOULD LOOK AT EACH MATERIAL NAME AND THICKNESS COMBINATION TO BE SURE THE CORRECT WIDTH AND 

LENGTH IS SPECIFIED. 

 

 

 

 

 

 

 

Figure 20 Redesigned Sheet Optimization Settings dialog box 
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Cut & Paste Instances on Optimized Sheet  
Added the ability to cut and paste instances on a 

layout diagram for both Optimized Cut List Diagrams 

and Optimized DXF Diagrams dialog boxes. There are 

two new buttons called Add Sheet and Paste, shown 

in Figure 21, respectively. 

To move an instance from one sheet to another, 

follow this sequence: 

a) Click on an instance to select it. You will see it 

highlighted in the Sheet Materials List. 

b) Click the paste button. 

c) A dialog box will appear asking for the sheet you 

want to put the instance on. The last sheet is 

suggested because it is usually the one with unused 

space. The user can change the sheet number as 

required. Click on the OK button. 

d) The sheet you specified will automatically scroll into 

view. Move your cursor around the sheet and notice 

as you do the instance will be displayed in one of 

three colors: Red, Orange or Green. Red means you 

cannot place it there. Orange means you can place it 

there, but you will not have the specified distances 

between objects that the others have. Green will appear when you are within two inches of an upper-

left or lower-right corner point of an adjacent instance, and means you will have the specified spacing. 

Click at that point and the instance will be placed and 

the diagrams will be updated. 

e) Sometimes the last sheet doesn’t have enough space 

to place an instance, or the number of instances you 

wish to place. So, you can add an empty sheet to the 

diagram with the Add Sheet Button. 

f) If you wish to abort a cut & paste, either click the 

Cancel button on the Select a Sheet dialog box in Figure 

22, or, if you are moving the selected instance on the 

target sheet, simply move the instance until it is red 

Figure 21 The new Add Sheet and Paste buttons 

Figure 22 The Select a Sheet dialog box always suggests 
the last sheet 
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and click. 

In addition to moving instances from one sheet to another, you can also move instances around on the 

same sheet using the same sequence. 

This feature is useful if you want to place door or drawer fronts on a sheet and arrange them for optimal 

grain matching, or perhaps you just want to cluster a certain type of parts on a sheet. 

A Word of Caution. Each time you press the Begin Optimization button on the Sheet Optimization 

Settings dialog box, CabWriter will begin optimization from the beginning, and any work you have done 

in moving instances around will be lost. Therefore, you need to print out your labels and layout sheets 

before you close either the Optimized Cut List Diagrams or the Optimized DXF Diagrams dialog boxes. In 

the case of the Optimized DXF Diagrams, you also need to save the Sheets Folders containing the DXF 

files, because those too will be regenerated from the beginning and all your changes will be lost. 

Eliminate Any Instances or Cabinets from Any Report by Hiding Them 
There are four scenes used in CabWriter Production 

Documentation to create the various reports shown in 

Figure 23. You can now use the Entity Info dialog box 

Hide icon (eye), or menu Edit > Hide, to hide an 

instance(s) in a scene. Subsequently, any reports 

generated using that scene will not include any hidden 

instances. The scene assigned to Purchased Part 

Report is used to generate the Drawer Fronts Report, 

the Drawer Boxes Report and the Doors Report. These 

three reports are included in the file called door_and_drawer_schedule.csv. 

The scene assigned to Rough Lumber Report is used to create the Rough Lumber report and generates a 

file called rough_lumber_schedule.csv. The scene assigned to the DXF Report is used to generate the 

optimized DXF layouts and to produce all of the DXF files. 

The scene assigned to the Cut List Report is used to create the cut list files, and this file is very special; it 

is the database for all the other reports. Therefore, the user must be careful not to hide instances in the 

Cut List Report scene, if those instances are to be included in any of the other scenes. Said another way, 

the Cut List Report scene must include all instances included in any other report. Typically, all CabWriter 

instances should be in the Cut List Report, however, if the user is careful about the above rule, instances 

can be hidden in the Cut List Report scene to produce a smaller, targeted, cut list. 

Note: Normally, once you have used File > CabWriter Production Documentation, you can use File > 

CutList Bridge > Sheet Optimization as many times as you wish. That way you can change optimization 

settings and see the results. However, if you change the visibility of a component on the DXF Report 

scene, you must go back to File > CabWriter Production Documentation before optimizing any layouts. 

Figure 23 The Scenes Used in Reports section of the 
Production Documentation dialog box 
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Construction Hole Depth 
Up till now, construction holes have been assumed to be through holes. Some cabinetmakers use 

dowels and need construction holes that are drilled to a specified depth. So, we added a new parameter 

default to the CNC Boring tab in the Construction Holes section called Hole Depth. See Figure 24. This 

permits construction holes that are not through holes. 

To accommodate this change, two new parameters were added to the CabWriter Settings CNC Setup 

tab, shown in Figure 25. 

 

 

Figure 25 CNC Setup tab with new parameters 

Figure 24 Construction Holes section of the CNC Boring tab with new Hole Depth parameter 
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In the General section is a parameter called Drill Layer(s). There are two choices: 

 

a) All holes are on the Drill Holes layer – This is the factory default 

b) Use Drill Partial & Drill Through layers 

 

In the DXF Layers section is a new layer called Drill Holes. With this new layer the user has much more 

flexibility in layer naming and layer organization. Here are some changes in CabWriter V. 

 

Prefix 1, Prefix 2 and Prefix 3 Supports Spaces 

Any of the user defined Prefixes can contain, begin and/or end with a space character. This makes layer 

names more readable. 

 

Hole Depth Is Embed-able in the DXF File 

DXF files generated by CabWriter V can have all geometry depth embedded in the DXF file(s). If the CAM 

software you are using reads this embedded depth you can use it for tool path-ing and can leave Prefix 2 

and Variable 2 blank. The default in the General section called Include Z-Depth in DXF controls whether 

or not the geometry depth is embedded. The default is No. 

 

Drill Layer(s) Set to All on Drill Holes 

With this option the layers called Drill Partial and Drill Through in the DXF Layers section are ignored. All 

drill hole layer names are generated using the construction defined by Drill Holes. For example, if you 

want all drill holes of a given diameter, and drilled with a specified bit name, independent of hole depth, 

simply leave Drill Holes Prefix 2 and Variable 2 blank. 

 

Drill Layer(s) Set to Use Drill Partial/Through 

With this option the Drill Holes layer is ignored. Holes that are drilled the thickness of the board have 

layer names generated using the construction defined by Drill Through. Holes that are less than the 

thickness of the board have layer names generated using the construction defined by Drill Partial. 

Z-Depth Option (CNC) 
Added a new parameter to the CNC Setup tab in the 

General section called Include Z-Depth in DXF. See 

Figure 26. The default is No. A Yes default will add the 

depth of a part, hole, pocket etc. to the DXF file, giving 

the DXF a 3D look. Some CAM software uses this Z-

Depth to aid in automatically generating tool pathing. 

A No default, the default case, leaves out the Z-Depth 

and provides a 2D DXF. 

Figure 26 General section of the CNC Boring tab 
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Ladder Base Thickness 
We decoupled the Ladder Base 

thickness from the carcass thickness. 

Carcass thickness is defined by 

Side/Partition Thickness in the Base and 

Upper Carcass sections of the Base 

Cabinets and Upper Cabinets tabs 

respectively. In the past this parameter 

determined the thickness of the Ladder 

Base too. With the addition of a new 

default called Ladder Thickness, to the 

Toe Kick section of the Carcass tab, the 

Ladder Base has its own thickness. The 

default for Ladder Thickness is ¾”. See 

Figure 27. 

 

 

 

Figure 27 Toe Kick section of the Carcass tab with new Ladder Thickness 
parameter 


