
CabWriter 4.0.0 Release Notes 6-25-2020 

New Functionality 

1. I believe it was SketchUp Version 2019 that 

Trimble fixed the Make Unique and re-naming 

of components in the Entity Info dialog box to 

save the attributes. Unfortunately, the way 

they fixed it didn’t account for the way 

CabWriter stored attributes and these tools 

continued to lose attributes of CabWriter 

components. 

 

To solve this problem, and to remove the 

restriction of not re-naming CabWriter 

components with the Entity Info dialog box, or 

to not use Make Unique, we changed where & 

how CabWriter stores its attributes. Now, if 

you open a model created in a CabWriter version prior to this release (including all CabWriter 4 

beta releases) and try to use any CabWriter tool, you will get the dialog box shown in Figure 1. 

 

This dialog box give you a message that lets you know that the model you are working on is not 

compatible with this version of CabWriter. If you want to make it compatible you can select Yes 

for the Update Model Now drop down and click OK. However, before you do this you should 

save a backup copy of the model, because once updated, you cannot use it in an older version of 

CabWriter. Further, if the process of updating should create a problem, you want a backup to 

fall back on. Once you update a model it is marked as being created in this base version of 

CabWriter and you will not have to update it again for the life of CabWriter 4.0.0 release. 

 

In addition to updating your model for this version, you have the opportunity to Update Defaults 

Files. Defaults files are not model specific, rather they are stored and available to all models. So 

you only have to update them once for this new CabWriter release, whereas any older model 

needs to be updated the first time you try to use it in this release. 

 

This change should make it easy for users to work with this release and you can use this method 

of update and not have to use Re-Load Factory Settings (RFS) or Extension > CabWriter > Update 

Defaults Files. 

 

As a result of this change you can now: 

          a) Use the native Entity Info dialog box to change a component name or instance name 

while preserving its attributes and DNA (stored defaults and cabinet definition). But be careful; if 

you change a prefix you may detach it from its cabinet, or if you change a description you may 

Figure 1 Update Model dialog box. 



create other problems. CabWriter is very strict about its naming conventions and you need to 

obey them. 

          b) You can use Move/Copy and Make Unique to copy a CabWriter component with all its 

attributes and component DNA and rename it. 

 

2. Updated the following dialog boxes to conform with the new (since SketchUp 2017) 

UI::HtmlDialog Ruby class. 

a. Make CabWriter Component 

b. End Selector 

c. Modify End Selector 

d. CabWriter Web Page (Extensions > CabWriter > Purchase a License) 

e. LayOut Document SetUp 

f. Defaults File Selector 

g. Activate CabWriter License 

h. Section View 

i. CabWriter Message 

j. Assign Layers 

k. Provide a Wall Name 

l. Back Panel 

m. View License and Check for Updates 

n. Extended Entity Info 

 

3. Added a check for version update. Every seven 

days, when opening SketchUp, a check will be 

made to see if the installed version of 

CabWriter is the latest version. If it is not, a 

message, shown in Figure 2, will inform the 

user that a newer version is available for 

download. 

 

4. Changed the Construct Walls tool’s Provide a 

Wall Name dialog box to open with the OK 

button as the element with focus, shown in 

Figure 3. This allows the user to easily accept 

the default name by simply pressing the Enter 

key. 

 

5. Changed the Blind/Butt Corner Stile parameter 

in the Upper Stiles & Rails section of the Face 

Frame tab to a default of 1 ¾” to match that of 

the same parameter in the Base Stiles & Rails section. 

 

Figure 2 A newer version is available message. 

Figure 3 OK Button now has focus so the user can simply 
press Enter to accept a default name. 



6. Made a change that allowed frameless cabinets that were next to each other, that is cabinets 

that did not share the same Story Stick but butted against one another, to have consistent 

vertical gaps between their doors and drawer fronts. To accomplish this the user must specify 

connectors at the ends of the cabinets that are to butt one another. These connectors are not 

drawn, but tell CabWriter that the user is expecting to butt another cabinet to this one and 

divides the gap by two. 

 

7. In the past it was assumed that if Side Setback was used that both stiles of a box were drawn. 

We implemented a change that now do not require this. For example, you can specify a 1 5/8” 

End Sheet stile that is drawn in an otherwise pure frameless design and have a 1/8” Side 

Setback. The sides behind the End Sheet Stiles will be set back 1/8” but the sides behind virtual 

(non-drawn) connector stiles are not affected by the setback. 

 

8. This change may also be classified as a bug fix. In the past slab doors were oversized in thickness 

based on the value of the parameter Frame & Panel Thickness found in the Door & Drawer 

Oversizing section of the CabWriter Settings Cut List tab. This is now conditioned such that if the 

specified material for a slab door or drawer front is type Sheet Good, no thickness oversizing is 

applied. If slab doors or drawer fronts are type Rough Lumber, thickness oversizing will be 

applied. 

 

9. Changed Extensions > CabWriter > Purchase a License menu item and the View License and 

Check for Updates dialog box Download Latest Version button to open the respective CabWriter 

web pages in the user’s default browser instead of the SketchUp built-in browser. The latter has 

limited functionality and did not accurately display the web pages. 

 

10. This change might be also filed under Fixes. Changed the menu command File > CabWriter > 

Create Basic Scene Set to include all layers that contain one or more CabWriter component in 

the CutList scene. This means if a component has a CabWriter prefix such as C11LCP Large Island 

Top, the layer it resides on will be included in the Cut List scene. In the past if for example, Doors 

& Drawer Fronts were placed on the DXF scene, they were then left off the Cut List scene and 

the user would get the following error message when using File > CabWriter Production 

Documentation.  

Figure 4 A warning message that the named part(s) do not have component numbers 
assigned. 



11. Made numerous changes to how File 

> CabWriter Production 

Documentation works. In the past, 

when the user selected the menu File 

> CabWriter Production 

Documentation, a message box would 

appear warning that this operation 

could take several minutes and the 

user should close the Outliner if open. 

 

Now, when the user selects the menu 

File > CabWriter Production 

Documentation, a Production 

Documentation Setup dialog box 

appears. It still has the warning of the 

old message box, but it now has four 

options in addition. We added this 

dialog box because at least one popular CNC vendor’s CAM software will only accept DXF files in 

metric units, regardless of the units the model was created in. For imperial users who do not 

have this problem with their CNC software or vendor, you can simply press enter on the 

keyboard. 

 

In addition to this Production Documentation Setup change, we have made another change. File 

> CabWriter Production Documentation and File > CutList Bridge > Sheet Optimization are 

separate menu commands, but both are part of the production documentation package. In the 

past, at the completion of CabWriter Production Documentation a message would appear that 

told the user where the documentation was stored, and the user released the message by 

clicking the OK button. Now, when you click the OK button CabWriter proceeds to sheet 

optimization just as if the user chose File > CutList Bridge > Sheet Optimization. You can still use 

the File > CutList Bridge > Sheet Optimization command separately and as many times as you 

wish, However, to make the settings in the Production Documentation Setup applicable to both 

documentation processes, they have been joined as one with the issuance of File > CabWriter 

Production Documentation. 

 

Imperial users who do have the requirement to provide Metric DXF files can select Metric units 

in the Units Format drop down. You may also need to change the Measurements Multiplier drop 

down setting. With the latter change of tying File > CabWriter Production Documentation and 

File > CutList Bridge > Sheet Optimization together, whatever Units Format is chosen will apply 

to both operations. 

 

Imperial users who are using CAM software that requires production documentation (DXF files) 

in Metric, may want two sets of documentation, all the way through optimization and printing 

Figure 5 New Production Documentation Setup dialog box. 



out optimized sheets and labels. Those users would run File > CabWriter Production 

Documentation twice; once with Units Format set to Metric and again with Units Format set to 

Imperial. 

 

If you have designed your model in Imperial units, and that is the preferred units for your 

production documentation, but need the Metric DXF files, you should make your first pass with 

Metric selected for Units Format and Yes selected for Restore Units. That way, at the end of the 

Metric pass your Imperial units will be restored. 

 

If you are producing Metric Sheet Optimization, you should consider setting Display Units to No. 

This will avoid double line heights in the cut list due to too many characters in the dimension 

fields. 

 

12. The Production Documentation dialog box, shown in Figure 7, has undergone substantial 

changes. Added the ability to include the Project Name in the Label Printing feature. In Figure 7, 

each Line #: now has included in its drop down the Project Name option. The Project Name is 

taken from the Project Name section of the Project tab. Recall that this name is initially taken 

from the SketchUp file name when the CabWriter project is created, but can be changed to 

another name by the user. Be sure that this name has no illegal directory or file characters. Note 

that the first line of a label is in bold text and the second line is italicized. This is to aid in quick 

identification when adding labels to milled parts. The user should judiciously choose the 

information that helps most in the first two lines. 

 

13. Added the Stiles & Rails scene to the File > 

CabWriter > Create Basic Scene Set suite of 

scenes. Now when you use this tool The Assign 

Layers to Scenes dialog box drop downs will 

have an additional choice: Stiles & Rails. If you 

have a face frame design and want the stiles 

and rails of the door and drawer fronts to be 

included in the Stiles & Rails report they should 

be assigned to the Stiles & Rails scene. Drawer 

Boxes cannot be assigned to this scene because 

they do not include any stile and rail parts. 

 

14. Changed the place the selections on the Production Documentation dialog box are saved. In the 

past, any selection made on the Production Documentation dialog box was saved with the 

project model. The problem was, these selections had to be made for each model, and with 

there now being a possibility of six label formats, that became cumbersome. They are now 

saved with the CabWriter extension, so they only need to be set up once and will apply as a 

default for any model. Of course, while working on any model they can be changed. 

 

Figure 6 Assign Layers to Scenes dialog box. 



  

Figure 7 Numerous changes have been made to the Production Documentation dialog box. 



15. Changed the Draw > CabWriter > Create Section From Section Plane menu command so that the 

user can select a current section plane, even if it is not the active section plane (a section cut is 

not displayed), include it with the cabinet(s) selection, and use it for the purpose of this 

command. CabWriter will make the selected section plane active and produce the scene. 

 

16. Implemented native CabWriter sheet optimization. 

 

Let’s start with some nomenclature. An optimized sheet layout, when viewed on the screen, shows the 

Length of a sheet in the X or horizontal direction, Width of a sheet in the Y or vertical direction, and the 

Thickness of a sheet in the Z or normal to the screen direction. The sheet origin is in the lower left 

corner and has an X,Y value of 0,0. Note that for sheet material with grain, the grain will normally run in 

the X direction. See Figure 8. 

 

CNC Setup Tab 

In the Cutting Bit Table section of the CNC Setup tab of the CabWriter Settings dialog box is the Outside 

Profile parameter with sub-parameters Diameter and Name. See Figure 10. The Diameter sub-

parameter default of the Outside Profile parameter is added to the Clearance parameter in the CNC 

Settings section of the Sheet Optimization Settings dialog box to produce the Channel Width. See the 

Sheet Optimization Settings dialog box in Figure 9. 

 

Channel Width = Diameter + Clearance 

 

Channel Width is not a CabWriter parameter, nor is it a Sheet Optimization setting. It is a calculation 

Figure 8 A CNC optimized sheet showing major parameters. 



CabWriter makes and uses in its optimization code. Channel Width is the internal spacing between 

parts; internal spacing means all spacing except Edge Margin, found in the CNC Settings section of the 

Sheet Optimization Settings dialog box. See Figure 9. 

 

Sheet Optimization Settings Dialog Box 

To accommodate the new optimization tool a new setting dialog box has been added called Sheet 

Optimization Settings. See Figure 9. This dialog box is opened either at the end of a File > CabWriter 

Production Documentation menu has produced a cutting list, or directly with File > CutList Bridge > 

Sheet Optimization. Figure 9 shows the Sheet Optimization Settings dialog box with a material name of 

MDF chosen. In this example there are more than six available sheet sizes. You can use the scroll bar on 

the right to scroll through all of them. 

 

Note: You must first use the File > CabWriter Production Documentation menu command to produce a 

cut list before you can use the File > CutList Bridge > Sheet Optimization menu command directly. Failing 

to do so may produce the message shown in New Functionality item 3. However, once you have 

produced a cut list you can use the File > CutList Bridge > Sheet Optimization menu command over and 

over with different settings to see various results and choose the one that best suits the user’s purpose. 

 

Default Sheet Format Section 

At the bottom of Figure 9 is the Default Sheet Format section. The purpose of the Default Sheet Format 

parameters is to tell CabWriter the user’s preferred sheet format and whether that format has grain. If, 

for example, an entire project was to use MDF ¾” X 5’ X 8’ without grain, a common MDF format, the 

user might set these defaults in the drop-down fields for Thickness, Width, Length and Has Grain? 

respectively: ¾”, 60”, 96”, No. 

 

The following parameters are the Default Sheet Format section defaults. 

 

Thickness - Default is ¾” (19mm) 

Width - Default is 48” (1219mm) 

Length - Default is 96” (2438mm) 

Has Grain? - Default is Yes 

 

General Optimization Settings 

The General Optimization Settings section has two defaults. 

 

Rotate Grain-less Sheet Parts for Optimization 

This is a Yes/No drop-down setting. When set to Yes, if a part is being placed on a sheet that does not 

have grain, the optimizer is free to rotate it if doing so achieves better optimization. The default is Yes. If 

the user wishes that no part be rotated the user should select No. 

 



Ignore Grain Direction 

This is a Yes/No drop-down setting. When set to Yes, it is equivalent to specifying all sheets used in the 

project as having no grain. This might be useful if the user intends to paint plywood material. The 

Default is No. 

 

CNC Settings 

This section contains settings that apply to DXF file generation for CNC cutting. 

 

Edge Margin 

This setting specifies cutting bit margin around the four edges of a sheet material where there may be 

edge damage. The default setting is ¼” (6.4 mm). 

 

Diameter 

Diameter is NOT found in the CNC Settings section of the Sheet Optimization Settings dialog box. Rather 

it is found on the CNC Setup tab of CabWriter Settings as described above in CNC Setup Tab. It is 

repeated here to emphasize it is added to the Clearance parameter in the CNC Settings section of the 

Sheet Optimization Settings dialog box to produce the Channel Width. The Clearance parameter is the 

one described below. 

 

Figure 9 The new Sheet Optimization Settings dialog box. 



Clearance 

Clearance is a setting provided to protect a part that has already been defined by an outside profile cut, 

from being damaged or shrunk by an outside profile cut of an adjacent part. The default is 1/8” (3.2 

mm). The Clearance setting is added to the Diameter default, shown in Figure 3, to produce the Channel 

Width shown in Figure 1. 

 

Nesting Direction 

Nesting direction is a setting used by the optimization code to determine where sequential parts are 

placed. The default is Optimum. The user can choose Rip Cut, Cross Cut or Optimum. Optimum will 

achieve the best results, i.e. use the fewest sheets. If the user prefers rip cuts for the first few milling 

cuts then Rip Cut is the correct setting. If the user prefers cross cuts for the first few milling cuts then 

Cross Cut is the correct setting. 

 

Table or Panel Saw Settings 

This section contains settings that apply to cutting diagrams for table and panel saw milling. 

 

Edge Margin 

This setting specifies saw blade margin around the four edges of a sheet material where there may be 

edge damage. The default setting is ¼” (6.4 mm). 

Figure 10 The CNC Setup tab Cutting Bit Table with the Outside Profile Diameter default. 



 

Saw Kerf 

The Saw Kerf is the width of the cut made by a saw blade. The default is 1/8” (3.2 mm). The Saw Kerf 

setting is added to the Clearance setting, below, to produce the Channel Width. 

 

Channel Width = Saw Kerf + Clearance 

 

Channel Width is the internal spacing between parts; internal spacing means all spacing except Edge 

Margin. See Figure 1. 

 

Clearance 

Clearance is a setting provided to protect a part that has already been defined by a saw blade cut, from 

being damaged or shrunk by a saw blade cut of an adjacent part. The default is 1/8” (3.2 mm). 

 

Nesting Direction 

Nesting direction is a setting used by the optimization code to determine where sequential parts are 

placed. The default is Optimum. The user can also choose Rip Cut, Cross Cut or Optimum. Optimum will 

achieve the best results, i.e. use the fewest sheets. If the user prefers rip cuts for the first few milling 

cuts then Rip Cut is the correct setting. If the user prefers cross cuts for the first few milling cuts then 

Cross Cut is the correct setting. 

 

Material Name & Grain Style 

The Material Name & Grain section has two fields that permit the user to choose whether a material has 

grain or not. 

 

Material Name 

A drop-down field called Material Name is provided so the user can select a material name and review, 

add or delete the sheet formats available for use in the optimization process. The material names in the 

list are the same as the Sheet Goods Material Name list, the same list that is used in CutList Bridge and 

on the Materials tab of the CabWriter Settings. 

 

Has Grain? 

A Yes or No setting indicating whether sheets of the selected Material Name has grain. Parts placed on 

sheets without grain are eligible for rotation for better sheet optimization results. Notice that this 

setting applies to all formats of a given Material Name. 

 

Available Sheet Sizes for Selected Material Name 

When a material name is selected from the Material Name drop-down, this section is populated with 

the currently available sheet sizes for sheet optimization in a table format. If a sheet size is not currently 

available it may be added using the Add Line button or a currently available size can be deleted using 

the Delete Line button. The user may also use the fields under the Thickness, Width and Length buttons 

to change a currently available size. In this way the user tells CabWriter the size sheet it wants the 



optimizer to consider in its sheet optimization process. 

 

When this dialog box is opened CabWriter automatically adds a sheet size for each sheet good material 

name and thickness combination used in the project. The length and width of that sheet size is the 

Length and Width shown in the Default Sheet Format section. 

 

Add Line 

Add Line is a button that will add a blank line to the table. 

 

Delete Line 

Delete Line is a button that will delete a line from the table. To delete a line, you must first select it by 

selecting the radio button to the left of the line, and then click the Delete Line button. 

 

Thickness 

Thickness is both a column heading and a button. When the Thickness button is pressed it will sort the 

table in “alphabetical order” by Thickness. Because of the way sorting is done in Ruby code, alphabetical 

order really means grouping. 

 

Width 

Width is both a column heading and a button. When the Width button is pressed it will sort the table in 

“alphabetical order” by Width. Because of the way sorting is done in Ruby code, alphabetical order 

really means grouping. 

 

Length 

Length is both a column heading and a button. When the Length button is pressed it will sort the table in 

“alphabetical order” by Length. Because of the way sorting is done in Ruby code, alphabetical order 

really means grouping. 

 

Close Button 

The Close button will save all changes made to the Sheet Optimization Settings and close the dialog box. 

 

Begin Optimization 

The Begin Optimization button will save all changes made to the Sheet Optimization Settings, close the 

dialog box and begin the optimization. Figure 12 shows a typical optimized sheet. A blue instance is one 

that has not been rotated while a yellow instance is one that has been rotated. Noted on each instance 

is the instance label, in this case the component name, length and width dimensions and the Info 

information indicating which dimensions have been re-sized. Above the sheet is the sheet number, 

material name and the material format dimension. 

 



When the optimization is complete the Optimized Sheet Diagrams dialog box will automatically open. It 

will open and display the optimized results for the first Material Format on the drop-down list shown in 

Figure 11. In this case that is Maple Plywood – ¾” x 48” x 96”. The optimized sheet in Figure 12 is the 

result.  If the user selects another format, such as the one highlighted in Figure 11, the dialog box 

changes to the one shown in Figure 13. 

 

Notice in Figure 11 that the formats are grouped by material name. You must pick a format under a 

material name and that set of sheets and their cut list will populate the dialog box along with 

optimization results. In Error! Reference source not found. you see the results for Maple Plywood – Pre-

Finished ½” x 48” x 96” shown. Each time you make 

another selection from the Material Format drop 

down you will see different results. Let’s walk 

through the Optimized Sheet Diagrams dialog box in 

detail. 

 

Optimized Cut List Diagrams Dialog Box 

The Optimized Cut List Diagrams dialog box is a 

rather large box in terms of pixel height and width. 

It has scroll bars which can be used on display 

resolutions smaller than necessary to view the 

whole dialog box. 

 

Sheet Display Area 

The Sheet Display Area is the area in the dialog box 

that the sheet diagrams reside. In Figure 13 & Error! Reference source not found. you will notice that 

Sheet 1 is shown along with a portion of Sheet 2, and there is a rather large blank area to the left of 

Sheets 1 & 2. The Sheet Display Area is sized to accommodate up to a 60” x 120” sheet good. However, 

you will need to be printing on paper larger than letter size 8 ½” x 11” to accept it. 

 

Each sheet displayed will have the sheet number, material name and format above the sheet. A blue 

instance is one that has not been rotated while a yellow instance is one that has been rotated. Noted on 

each instance is the instance label, in this case the component name, length and width dimensions and 

the Info attribute information indicating which dimensions have been re-sized. 

Figure 11 Material Formats & Name drop down. 



 

Sheet Materials List 

The Sheet Materials List contains the cut list for the material name and format chosen. It is NOT the 

entire cut list for the project, only the portion that applies to the material name and format chosen. 

There is a scroll bar to the right to permit scrolling through the entire list. The user can click on any 

instance in the Sheet Display Area and its entry in the cut list will be highlighted; C6-17 C6LB3 Blind 

Front is highlighted in Figure 13. 

Note that the dimensions show on each instance in the display area are those in the Width and Length 

columns of the cut list; these are the initial cut dimensions taking into account any re-sizing. Fin W and 

Fin L columns show the final width and final length dimensions. 

 

Material Formats & Name 

This section of the Optimized Cut List Diagrams dialog box is where the user begins; it is immediately 

opened after optimization is completed. CabWriter examines the entire model and collects all of the 

materials and their thicknesses. It then looks at the preferred format shown in the Sheet Optimization 

Settings dialog box in section Default Sheet Format shown in Figure 9. It then organizes this information 

into a drop-down labeled Material Format. An example is shown in Figure 11. Once the user selects a 

format the Material Name field is filled in. The Material Name field is locked and not changeable by the 

user. 

 

Display Options 

The Display Options section permits the user to choose what is displayed inside each instance’s 

rectangle. Four radio buttons allow for a choice of one label format: part Description and Part # (the Part 

# is pre-pended to the part Description), part Description only, Part # only, Sub-Assembly only. Two 

Figure 12 A typical CabWriter optimized sheet. 



check boxes allow for displaying the instance’s Dimensions and/or Info || Banding (re-sizing dimensions 

Info and Banding separated by a double pipe). 

 

The instance’s label will appear in the lower left corner, and in the horizontal direction, of un-rotated 

instances. Note that for rotated instances (yellow rectangles in Figure 12 through Figure 14s), the label 

appears in the lower right and in the vertical direction. The Length appears in the upper left and 

horizontal direction while the Width appears in the lower right and vertical direction. The Length 

generally appears in the horizontal or X direction unless an instance is rotated. The Info is centered in a 

part. Note that for rotated parts the Dimensions and Info are rotated just like the label information. 

 

Print Options 

The user can print the cut list shown in the Sheet Material List section and the sheet diagrams. Which of 

these can be chosen from two check boxes labeled Diagrams and Cut List. These lists and diagrams are 

designed to print in the Landscape paper orientation and in color (or gray scale). The user does not have 

to manually choose these options in the Print dialog box. CabWriter takes care of that. 

 

CabWriter can also print labels with one to ten selectable lines of information on Avery 5160 or 5163 

label stock. The drop-down labeled Label Format provides this choice. Labels are printed in the order 

that instances are placed on sheets. 

 

Buttons 

There are five buttons at the bottom left: Close Optimized Cut List Diagrams, Label Preview, Label 

Preview, Sheet Preview and Sheet Print. The Close Optimized Cut List Diagrams button will simply close 

the Optimized Cut List Diagrams dialog box, and the Cut List Preview dialog box if it is open. However 

you close the Optimized Cut List Diagrams dialog box, whether by using the Close Optimized Cut List 

Diagrams button or the box’s close X icon, if you have produced DXF optimized files during CabWriter 

Production Documentation you will be taken to another optimization dialog box called Optimized DXF 

Diagrams. 

 

The Label Preview button will open a dialog box that will preview a partial sheet of label stock print out 

reflecting the Label Format chosen with the Label Format drop-down. The Label Print button will open 

the system’s Print dialog box to permit the user to print the label stock. 

 

The Sheet Preview button opens the Cut List Preview dialog box which will provide an overview page 

followed by the Cut List and Cut List Diagrams. The Sheet Print button will open the system’s Print dialog 

box. Upon printing the Cut List Preview box will automatically close.  
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Optimization Results 

This area shows the results of the optimization. The first five lines are taken from the Sheet Optimization 

Settings dialog box, shown in Figure 9. The first two lines are from the General Optimization Settings 

section. The next three lines are from the Table or Panel Saw Settings section. These default options are 

repeated in the Optimization Results just to make it easy for the user to recall the conditions under 

which the optimization was performed. 

 

The next line informs the user of the Total Number of Instances that are required to place. Note that 

these are instances (or parts), not components, and therefore can be greater than the number of lines in 

the Cut List. The second line indicate the Placed Instances as a part of the total. Notice in Figure 14 that 

38 of 39 instances were placed. When less than the total of instances are placed, a red set of lines will 

appear to indicate those instances that were not placed for some reason. In this case C6LB3 Back was 

not placed. An examination of that part in the model will show that it is too wide to fit on a sheet of 48” 

x 96” material. As the cabinetmaker you need to make a design change to correct the situation. 

The next line indicates “Total number of sheets = “, and reports an integer representing the total 

number of sheets optimized. This is followed by a set of three lines for each sheet with the sheet 

number, sheet efficiency percentage and wasted sheet percentage. The latter two may not add up to 

100%, because they are calculated differently. 

 

When using either the Sheet Preview or Sheet Print buttons, a cover page is created that includes the 

Optimization Results from the first line to the “Total number of sheets = “ line inclusive. Its heading is 

the project name. Its sub-heading is the material name and sheet format. A footer includes the project 

name, page number and total pages and the date of creation. This cover page is followed by the cut list, 

if selected, and the sheet diagrams, if selected. 

 

Optimized DXF Diagrams Dialog Box 

When the user closes the Optimized Cut List Diagrams dialog box, using either the Close Optimized Cut 

List Diagrams button or the box’s close X icon, CabWriter looks to see if the user requested a DXF by 

Material Name & Thickness report in the Production Documentation dialog box shown in Figure 7. If 

requested (checked) the Optimized DXF Diagrams dialog box opens as shown in Figure 15. This dialog 

box is very much the same as the Optimized Cut List Diagrams dialog box with the following exceptions: 

 

1. Actual shapes of parts are used and derived from the sheet optimized DXF files. 

2. Joinery is shown in the diagrams, including the cutting bit guide lines. 

3. The dimensions cannot be displayed, since they would not be useful anyway, and it avoids clutter. 

 

All other buttons and fields work exactly as the Optimized Cut List Diagrams. 
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17. Added the ability to mill slab door and drawer fronts on the CNC and allow for trim and banding. 

Up till now, when cutting slab doors and drawer fronts on the CNC, their dimensions were full 

size. That is, re-sizing (under-sizing in this case), does not apply to part milled on the CNC. This is 

because DXF files are generated by using the SketchUp component as actually drawn. We have 

now added the ability to draw trim or banding around a slab door or drawer front, hence making 

the actual slab smaller by twice the thickness of the trim/banding in both width and height. 

Hence, the door or drawer front is now milled to actual size. To do this we have had to add a 

new default and change the name of another. Be aware that if you intend to cut your door and 

drawer front on a table or panel saw you should not use this capability. It is only for user’s who 

wish to cut their doors and drawer fronts on the CNC machine. Further, you must make this 

choice BEFORE drawing any cabinets, lest you have to re-draw them to take advantage of this 

capability. 

 

Enable CNC Cutting: 

This new default is found in the General section of the CabWriter Settings Project tab and has 

two options: 

 

Yes – Selected only when the user wishes to mill slab door and drawer fronts on the CNC 

machine adjusted smaller to allow for trim or banding. CabWriter treats trim and banding as 

though they are the same except for thickness. 

 

No – Slab doors and drawer fronts can still be milled on the CNC machine, but they will be 

drawn to finished dimensions in the model and milled to finished dimensions on the CNC with 

no accounting for trim or banding thickness. CabWriter treats trim and banding as though they 

are the same except for thickness. 

 

Trim or Edge Banding Thickness:  

This default is a name change only from Edge Banding Thickness to Trim or Edge Banding 

Thickness. It is located in the Slab Door & Drawer Undersizing section of the Cut List tab. If 

Enable CNC Cutting is set to Yes, this default will define the trim/banding thickness. If Enable 

CNC Cutting is set to No, this default will define the cut list under sizing. CabWriter treats trim 

and banding as though they are the same except for thickness. 

 

Figure 16 shows a cabinet drawn with Enable CNC Cutting set to Yes. 



 

  

Figure 16 A frameless base cabinet with banded slab doors & drawer fronts. 



18. Implemented a change to add separate top and bottom door and drawer front gaps. These are 

the gaps between: the top of the door or drawer front and the top of the cabinet when the top 

rail is not drawn; and the bottom of the door or drawer front and the bottom of the cabinet 

when the bottom rail is not drawn. These new gap parameters only apply to door or drawer 

fronts at either the top of a cabinet or the bottom of a cabinet. They do not apply to doors or 

drawer fronts that are between other door or drawer fronts. 

 

When the top rail is drawn, the gap between it and the top of the door or drawer front will be 

defined by the existing Door/Drawer Gap in the General section of the Project tab. Likewise 

when the bottom rail is drawn, the gap between it and the bottom of the door or drawer front 

will be defined by the existing Door/Drawer Gap. 

 

Here is the summary of the parameters. 

 

Project Tab: 

Door/Drawer Gap - Defines vertical gaps & in-between horizontal gaps between door and 

drawer fronts. When either the bottom rail and/or the top rail is drawn, it will define the gap 

between that rail and the applicable door and drawer front. This parameter is not new. 

 

Door/Drawer Countertop Clearance – This parameter has been retired. 

 

Base Cabinets Tab: 

Door/Drawer Top Clearance - Defines the gap between the uppermost door/drawer front and 

the cabinet top (bottom side of countertop or divided base cabinet height) when no top rail 

exists. 

 

Door/Drawer Bottom Clearance - Defines the gap between the bottom most door/drawer front 

and the bottom of the cabinet when no bottom rails exists. 

 

Upper Cabinets Tab: 

Door/Drawer Top Clearance - Defines the gap between the uppermost door/drawer front and 

the cabinet top when no top rail exists. 

 

Door/Drawer Bottom Clearance - Defines the gap between the bottom most door/drawer front 

and the bottom of the cabinet when no bottom rails exists. 

 

19. Implemented changes to the Sink Base cabinet to allow the user to: choose whether to draw the 

back stretcher; and select a vertical font stretcher or a traditional horizontal front stretcher. The 

vertical front stretcher runs from the top of the sink cabinet down to a width of the stretcher 

below the door opening. This protrusion into the door opening provides a top door stop. Using 

the vertical front stretcher eliminates the need to cut out for the sink in the traditional 

horizontal front stretcher. Two new parameters have been added in a Sink Base section of the 



Base Cabinets tab. 

 

Base Cabinets Tab: 

Draw Back Stretcher – The default is Yes and results in drawing the back stretcher. A selection of 

No will cause the back stretcher to not be drawn. 

 

Draw Front Stretcher – The default is Horizontal and will cause the traditional horizontal front 

stretcher to be drawn. A selection of Vertical will cause a vertical front stretcher to be drawn. 

 

20. Implemented two new parameters that allow the user to extend the sides of a cabinet and/or 

inset the cabinets top. These parameters only apply to upper cabinets. 

 

Implemented the parameter called Top Inset in the Upper Carcass section of the Upper Cabinets 

tab. This parameter works much the same way as the Bottom Inset parameter. This parameter is 

handy if the user wishes to put trim or molding above the doors; or to include lighting above the 

cabinet.  You no longer have to use native tools to extend the sides, end panels, end sheets or 

top rail. 

 

Implemented a feature that allows the user to extend the sides of an upper cabinet a specified 

distance above the cabinet height. To facilitate this, we added a new parameter in the Upper 

Carcass section of the Upper Cabinets tab called Extend Sides. When this default is greater than 

0” the sides will extend above the cabinet height by that amount. This feature is useful for 

providing a structure for adding trim or molding. 

 

This Extend Sides parameter can be used in conjunction with the Top Inset parameter to allow 

for inset tops and extended sides as shown in Figure 17. 

 

21. Improved Production Documentation Performance. I used the Gracie Hopkins Kitchen (the 

kitchen used in the training videos CabWriter Comprehensive) to test the performance 

improvement. This model is a fairly large model and should be a good representation of 

performance improvement. Here are the results: 

 

Old Code - 115.93 seconds 

New Code - 72.19 seconds 

43.74 second reduction 

37.73% reduction 

 

The improvement is better if you intend to use the native CabWriter optimization and 

DXF generation and leave CutList Plus fx out of the CabWriter Production 

Documentation reports.  
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1. Removed ‘Printing Options’ from the Draw > CabWriter menu to make room for a new 

command; it should never have been there. 

 

23. Added a new menu item ‘Create Drawer Box 

Parts’ to the Draw > CabWriter menu. This 

menu tool replaces the drawer boxes created 

by CabWriter with five individual drawer box 

parts. There are five styles of drawer box parts 

implemented as shown in the drop-down in 

Figure 18. 

 

To use this tool choose menu Draw > 

CabWriter > Create Drawer Box Parts. The 

dialog box in Figure 18 will appear. You can 

choose the drawer boxes you want to replace either by selecting those boxes with the Select 

tool or by choosing a scene where they appear. Use the Replace By drop down and choose 

either Scene or Selection. If you choose Scene you must choose the target scene in the Use 

Scene drop down. Lastly, choose a style, for example Butt – Captured Sides, in the Replace With 

drop down. Click on OK and the Butt Style Drawer Box dialog box will appear, shown in Figure 

19. 

 

Most of the defaults are self-explanatory, but to aid the user, when the cursor is placed inside 

one of the input fields in the right column the picture will change to indicate what the 

parameter is, or means. When the defaults are selected click Draw and wait for the results. 

 

Users who intend to use this tool to replace drawer boxes with drawer box parts should follow 

this procedure: 

 

a. Before using Create Drawer Box Parts, be sure to use CabWriter Production Documentation 

and check Drawer Fronts, Drawer Boxes and Doors in the Select Desired Reports section of the 

dialog box. 

 

b. Use the Create Drawer Box Parts to replace the simple drawer boxes with the five box parts. 

 

c. If the material used in the drawer box parts is a sheet good and you want them to appear in 

your optimized cut list and DXF diagrams be sure to add the layer (now tag) they exist on to your 

CutList scene and DXF scene. 

 

d. Re-use CabWriter Production Documentation to create new cut lists that include the drawer 

box parts, but this time DO NOT check Drawer Fronts, Drawer Boxes and Doors in the Select 

Desired Reports section of the dialog box lest your get an error message and/or loose the 

drawer box report with the slider information in it. 

Figure 18 Drawer Box Type dialog box. 



 

You now can use File > CutList Bridge Sheet Optimization to produce cut list and DXF diagrams 

that include your drawer box parts. 

 

A number of new defaults have been added with the addition of this tool. Most of them are 

shown in the Butt Style Drawer Box dialog box shown previously in Figure 19. Four may require 

some explanation: Re-Size Length and Re-Size Width for the Bottom and also the Front, Back 

and Sides. These defaults behave exactly as Oversizing defaults on the Carcass tab. Whatever 

value exists in these fields with be added to the Length or Width of the part in the cut list Width 

and Length column. These represent the initial cut. The actual As Drawn dimensions will appear 

in the Fin W and Fin L columns representing the finished length and width. These may be 

particularly useful for the Bottom, which is going to fit into dadoes in the front, back and sides. 

You may wish to allow for glue by using a negative number such as -1/32”. 

 

There are some additional new defaults on the CNC Setup tab of CabWriter Settings in the CNC 

Drawer Part Milled Faces section shown in Figure 20. These let CabWriter know which face of 

each part is important and must be the one used to generate the DXF files. The default is Inside 

Figure 19 Butt Style Drawer Box dialog box for the Captured Sides option. 



because it is the inside of each of the Front, Back and Sides that have a dado that can be cut on 

the CNC machine. 

 

Figure 21 through Figure 23 show the five different types of drawer. 

 

 

 

 

  

Figure 20 Defaults added to the CNC Setup tab to accommodate CNC milling of drawer box parts. 

Figure 21 Butt Style Drawer with Captured Sides. Figure 22 Butt Style Drawer with Captured Front & Back. 



  

Figure 25 Butt & Dado Style Drawer. Figure 24 Tongue & Groove Style Drawer. 

Figure 23 Rabbet Style Drawer. 



24. Stored the CabWriter Base Version number in Layer0 CW Proj dictionary with attribute name 

CW_Version. This provides a way for CabWriter 4 and future versions to know what version of 

CabWriter a model was created in. With that information we can better handle compatibility 

with older model versions. 

 

25. Added a new report to the CabWriter Production Documentation suite of reports. It is called 

Stiles & Rails Schedule and it is found where Door & Drawer Schedule and Cut Lists are located. 

To understand how it works, begin by reviewing the new Production Documentation dialog box 

shown in Figure 7. To generate this report, you must create a scene and assign it to the Stiles & 

Rails Report as shown in the field labeled 1 in Figure 7. In the Gracie Hopkins Kitchen model, I 

called this scene Stiles & Rails. That scene contains only the Base Face Frames, Base Doors, Base 

Drawer Fronts, Base End Panels, Upper Face Frames, Upper Doors, Upper Drawer Fronts and 

Upper End Panels layers. In other words, any layer with a frame and panel construction on it. In 

this release, the File > CabWriter > Create Basic Scene Set command will automatically create 

this scene for you. (The scene’s tab will actually say Stiles – Rails because the & symbol doesn’t 

appear to work.) 

 

The Stiles & Rails Report can be very useful for designs that have complete face frames or partial 

face frames. The report analyses the face frames and give the user a Rip Cutting Schedule and a 

Cross Cutting Schedule. The Rip Cutting Schedule sorts by same material thickness and widths 

and tells you the linear feet (or centimeters) required. The Cross Cutting Schedule sorts by the 

same thickness, width and length and tells you the quantity required. This latter report can be 

very useful when cross cutting on a miter saw fitted with a computer-controlled stop, such as 

the TigerStop (https://configurator.tigerstop.com). 

 

The RIP Cutting Schedule will also give you an estimate of the number of bd-ft of rough lumber 

required based on standard industry practice of Quarter sizing. In the table below the Quarter 

Size is the rough lumber thickness you would buy at the lumber yard to get a maximum Planed 

Thickness. The Rough Cut is the thickness the board is cut prior to drying. CabWriter uses the 

initial cut thickness, which may include some oversizing, and chooses the smallest Quarter Size 

to allow for that thickness. 

Quarter Size Rough Cut Planed Thickness 

4/4 1-1/8” 13/16″ 

5/4 1-3/8″ 1-1/16″ 

6/4 1-5/8″ 1-1/4″ 

8/4 2-1/8″  1-3/4″ 

10/4 2-7/8” 2-1/8” 

12/4 3-3/8” 2-5/8” 

  

https://configurator.tigerstop.com/


Fixes 

1. Added a rescue and error message in the cw_methods.rb re_draw_cabinet to capture any 

CabWriter cabinet part that may not have CutList Bridge attributes. 

2. Changed the name of the Assign Layers dialog box to Assign Layers to Scenes to be more 

descriptive and accurate. This is the dialog box that appears with menu File > CabWriter > 

Create Basic Scene Set. 

3. Added an error message that will appear when no section cut can be made from the Draw > 

CabWriter > Create Section From Section Plane menu command. 

4. Corrected the Shelf/Fixed Shelf parameter in the CNC Milled Faces section or the CNC Setup tab 

to a default setting of Top. This is to allow the DXF file generation to mill the tongue including its 

rabbet. 

 

5. When the user chooses File > CabWriter to LayOut > Send Scenes to LayOut without first 

creating a user template in LayOut, an error message would appear in the Ruby Console. But if 

the user didn’t have the Ruby Console open then would be no indication of the error. I add an 

error message that appears in a message dialog box that explains what the user must do to 

resolve the problem. 

 
6. When drawing a Diagonal Corner Upper with an Overlay cabinet style the cabinet was not 

completed leaving the door un-drawn. 

 

7. When using the Story Stick tool, the user might occasionally get a measure indicating that the 

selected input point was not valid. That message was ‘You must pick a point on a Construction 

Point, Construction Line, Vertex or Edge.’. Following that message and after clicking OK, the user 

was left in a Select tool state. Now the user is automatically returned to the Story Stick tool at 

the state of the last successfully completed point. 

 

8. Somewhere in a previous beta release, CabWriter style files were either corrupted or SketchUp 

changed their internal format. The result was SketchUp bug splats after opening certain 

SketchUp files or new files if those files did not already contain the CabWriter styles. New 

updated files have been added. 

 

9. The use of 5/8" thick plywood resulted in three decimal digits (0.625) instead of two like 0.5 and 

0.75. That screwed up a variable name in my code (my bad). This could also occur with other 

sheet good thicknesses. However, the only problem it caused is that the Optimization Results 

section is left blank for that thickness. It didn’t affect anything of importance. It is now fixed to 

round 5/8”, or any thickness, to two decimal digits. 

 



10. Had to replace all the SketchUp files in folder Plugins\cabwriter\router_shaper_profiles because 

somewhere along the way they became corrupted. 

 

11. There was a problem with the CutList Plus fx radio buttons cluster on the Production 

Documentation dialog box, where the chosen radio button didn’t always produce a report 

consistent with the cluster’s settings. 

 

12. Changed the default CNC Edge Margin to 0.5” (12.8mm) to avoid a 3/8” cutting bit from going of 

the board. 

 

13. When drawing a Divided Upper the Cabinet Height parameter that CabWriter referenced was 

that for a Divided Base in the Base Cabinets tab, instead of the Divided Upper in the Upper 

Cabinets tab. Drawing a Divided Base worked just fine. 

 

14. When drawing a Lazy Susan Base with other that stile widths of 1 ½” (e.g. ¾”) in either Face 

Frame or Overlay Cabinet Style AND when drawing them as though you were standing facing the 

left wing of the cabinet, the Face Frame Rails were misplaced. 

 

15. Fixed some problems in the optimization algorithm that was producing less than desired results. 

 

16. Fixed a problem with CutList Bridge Setup tab, where choosing part numbering by CutList Bridge 

and Numerically didn’t stick and raised an error. 

 

17. When drawing a divided cabinet with two drawers on the bottom the drawer fronts were mis-

sized. 

 

18. Fixed a problem where choosing a Sub-Type in the Make CabWriter Component dialog box 

would not cause CutList Bridge attributes to be written if it were the second use of that dialog 

box in the current session. 

 
19. Fixed a problem where if you created CabWriter Production Documentation with DXF layer 

names different than the DXF layer names stored in the cabinets (those that were set at the 

time the cabinet was constructed) AND included a Drawer Boxes report request then the DXF 

layer names in the DXF file would be those stored in the cabinets. 

 
20. Fixed a problem where when creating CabWriter Production documentation the user might get 

an error message like the one below when there is actually nothing wrong with the model. It is 

actually a problem with the way SketchUp orders vertices of a face. This problem is likely to 

rarely show up except under unusual circumstances. 

 



 

 
21. Fixed a problem where an error would be raised if a user designed part were made a drawer box 

part using Make CabWriter Component. 

 
22. Fixed a problem where you couldn’t switch from the Materials tab to the Cut List tab in the 

CabWriter Settings dialog box. However, you were able to get to the Cut List tab from every 

other tab besides Materials. 

 

23. On the Materials tab, in the Materials section, I removed the 

option groups Specified Type and Unspecified Type as well as 

Primary Material and Secondary Material from the Type drop 

down lists. The Primary and Secondary Material are a CutList 

Bridge feature that allows CutList Plus fx to assign material. This is 

useful for non-CabWriter projects, but CabWriter requires the 

user assign material types and names in the application. These 

option groups will still be available in the Extended Entity Info 

dialog box. 

 

24. Fixed a Sheet and DXF Optimization problem where parts could be overlapping (occupying the 

same space). 

 

25. Fixed a problem with the Refrigerator Upper cabinet. If drawn with the cabinet sides NOT 

extended to the floor and with inset joinery, the insets and pockets where drawn incorrectly. 

 

26. Fixed a problem with Drawer Supports that are thicker than ½”. The right drawer support would 

appear to have no Drawer Slider holes because the holes were drawn from the left side and ½” 

deep, hence on a support greater than ½” thick they would not show. Drawer Slider holes drilled 

in the Drawer Support now go all the way through regardless of the thickness of the Drawer 

Support. 

 

27. Fixed a problem with hinge plate holes in Divided Cabinets. The front offset was referring to the 

shelf hole front offset default instead of the hinge plate hole front offset. It is now corrected. 

 



28. Fixed a problem with creating DXF files for the Rabbet Style and Tongue & Groove Style drawers. 

While this problem first appeared on these types of drawers, they could have shown up on 

other cabinet parts with the right combination of joinery default parameters. The user can now 

create DXF files that include Butt Style, Rabbet Style or Tongue & Groove Style drawers. 

 

29. Fixed a problem where the Thickness value for the Substrate layer would be the same for all 

thicknesses of plywood. 

 

30. Fixed a problem where rotated parts were not colored yellow on Print Preview, nor were their 

labels rotated. The same problem occurred if a format of plywood were selected a second time. 

 

31. Fixed a problem with the Lazy Susan Corner cabinet where the sides were not set back when the 

Side Setback in the Base Carcass section of the Base Cabinets tab was greater than zero. 

 
32. Fixed a problem with the Divided Base cabinet. When the bottom was inset the CNC hinge holes 

and shelf holes were placed too high in the sides by an amount equal to the bottom inset. 

 
33. Optimize Sheets didn’t work if the Model Info was set to Format Decimal and Units to 

Millimeters. Fixed numerous problems. 

 

34. Fixed a serious problem with the Extended Entity Info that crept in at the very beginning of 

CabWriter 4 changes; when we converted the remaining dialog boxes from the old style 

WebDialog to the new style HtmlDialog this problem was introduced. This problem caused 

component attributes to change if more then one component was selected at a time. In fact, all 

selected components would be set to only the common attributes and any other attribute 

would be set to empty. 

 

35. Fixed the ordering of points in DXF files such that they are all ordered in the counterclockwise 

direction. 

 
36. Fixed and issue with the Create a Back Panel tool where the panel could be drawn collapsed in 

the Z direction, i.e. drawn very short. This had to do with comparing floating point numbers 

different in only the least significant digits. 

 
37. Fixed an issue that was missed when Extend Sides was implemented. The Refrigerator Upper 

cabinet sides did not extend. 



38. Fixed and issue with File > CabWriter > Create Basic Scene Set. If you attempted to use this tool 

before assigning a hatch pattern to all materials you got the message below left. This message is 

lame and doesn’t give the user a clue as to the problem. So, I changed a number of things. First, 

I changed the message to the one on the right. 

 

   

 

Second, CabWriter now uses a default pattern for all CabWriter materials and wall called 

None. So, if you do not assign a hatch pattern to a material CabWriter will use None. 

None is a legal choice for a hatch pattern, however, if it is assigned intentionally by the 

user, or as a default by CabWriter, you will see an orange light next to the material type 

or wall as shown below. It is simply telling you that not all materials have a hatch 

pattern assigned. You only need to pay attention if you want a hatch pattern assigned to 

all materials. 

 

 
 

This is what the Material - Hatch Association section of the Materials tab will look like on a new 

project before the user assigns any hatches. If you see a red light instead of either orange or 

green, that is a catastrophic failure, likely meaning a hatch file is corrupt. 

 
39. Fixed a problem with the rough_lumber_schedule.csv report. If there was more than one 

material name in the rough lumber list, only one of those names were used in the board feet 

summary. 


